#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d+(?:,\d+)?) x (\d+(?:,\d+)?)(?: x (\d+(?:,\d+)?))?"
Local $sString = "Artikelgewicht3,7 Kg" & @CRLF & _
"Produktabmessungen60,4 x 46,5 x 42 cm" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"Artikelgewicht3,7 Kg" & @CRLF & _
"Produktabmessungen60 x 46 x 42" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"Artikelgewicht3,7 Kg" & @CRLF & _
"Produktabmessungen60 x 46"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")