package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(?:,\d+)?) x (\d+(?:,\d+)?)(?: x (\d+(?:,\d+)?))?`)
var str = `Artikelgewicht3,7 Kg
Produktabmessungen60,4 x 46,5 x 42 cm
or
Artikelgewicht3,7 Kg
Produktabmessungen60 x 46 x 42
or
Artikelgewicht3,7 Kg
Produktabmessungen60 x 46`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}