using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-\d]*)_(\w*)=([-\d]*)(\w*)";
string input = @"P-131_SPO=-200W";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}