$re = '/([-\d]*)_(\w*)=([-\d]*)(\w*)/m';
$str = 'P-131_SPO=-200W';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);