import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"([\\w\\s()]+)<.*?(\\w+)\\s+(\\[\\w+\\]\\s+\\(\\w+\\)).*$";
final String string = "\"КРОВАТЬ<img src=\"\"bed.png\"\" />\" BED [bed] (бэд)[sound:43.mp3]\n"
+ "\"ДОМ (место жилья)<img src=\"\"home4.png\"\" />\" HOME [həʊm] (хоум)[sound:23.mp3]\n"
+ "\"ЗУБ<img src=\"\"tooth2.png\"\" />\" TOOTH [tuθ] (туθ)[sound:30.mp3]\n"
+ "\"ЗУБЫ<img src=\"\"teeth.png\"\" />\" TEETH [tiːθ] (тииθ)[sound:31.mp3]\n"
+ "\"ИГРА<img src=\"\"game.jpg\"\" />\" GAME [geɪm] (гейм)[sound:32.mp3]\n"
+ "\"ЖУРНАЛ<img src=\"\"magazine.jpg\"\" />\" MAGAZINE [ˌmægəˈziːn] (мæгэзиин)[sound:28.mp3]\n"
+ "\"ЖИЗНЬ<img src=\"\"life.jpg\"\" />\" LIFE [laɪf] (лайф)[sound:27.mp3]\n"
+ "\"ЖЕНЩИНА<img src=\"\"woman (1).jpg\"\" />\" WOMAN [ˈwʊmən] (wумэн)[sound:25.mp3]\n"
+ "\"ЖЕНЩИНЫ<img src=\"\"women2 (1).jpg\"\" />\" WOMEN [ˈwɪmɪn] (wимин)[sound:26.mp3]\n"
+ "\"ЕДА<img src=\"\"food.jpg\"\" />\" FOOD [fuːd] (фууд)[sound:24.mp3]";
final String subst = "\\L\"\\2\";\"\\3\";\"\\1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}