#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Z]|[A-Z][A-Z]|[A-X][A-F][A-D])(?:[1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9]|[1-9][0-9][0-9][0-9][0-9][0-9]|10[0-3][0-9][0-9][0-9][0-9]|104[0-7][0-9][0-9][0-9]|1048[0-4][0-9][0-9]|10485[0-6][0-9]|104857[0-6])$"
Local $sString = "A1" & @CRLF & _
"AA11" & @CRLF & _
"AAA111" & @CRLF & _
"ZZ12" & @CRLF & _
"YY1048575" & @CRLF & _
"XFD1048576" & @CRLF & _
"A0" & @CRLF & _
"AA01" & @CRLF & _
"AAZ1111111" & @CRLF & _
"XFE1048576" & @CRLF & _
"XFD1048577" & @CRLF & _
"ZZZ333" & @CRLF & _
"ZZZ9999999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")