using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?'s'text)\s?(?'a'[^\]]*)\](?'c'.*?)\[\/(?'e'text)\]";
string input = @"[text color=""red"" data=""25\]""]red url[/text][text]url[/text]";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}