re = /\[(?'s'text)\s?(?'a'[^\]]*)\](?'c'.*?)\[\/(?'e'text)\]/i
str = '[text color="red" data="25\\]"]red url[/text][text]url[/text]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end