package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[text.*?\]([^\]\[]*?)\[\/text\]`)
var str = `[text color="red" data="25\]"]red url[/text][text]url[/text]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}