$re = '/\[text.*?\]([^\]\[]*?)\[\/text\]/i';
$str = '[text color="red" data="25\\]"]red url[/text][text]url[/text]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);