package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{4}-\d{2}-\d{2}`)
var str = `"created_at":"2017-05-08T14:01:25.903Z"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}