$re = '/\d{4}-\d{2}-\d{2}/';
$str = '"created_at":"2017-05-08T14:01:25.903Z"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);