#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^a+(?:bba+)*(?:bb)?$"
Local $sString = "a" & @CRLF & _
"aaa" & @CRLF & _
"abb" & @CRLF & _
"abba" & @CRLF & _
"abbabb" & @CRLF & _
"abbabba" & @CRLF & _
"aaabbaabb" & @CRLF & _
"abbabbabbaaa" & @CRLF & _
"" & @CRLF & _
"aba" & @CRLF & _
"baba" & @CRLF & _
"baabb" & @CRLF & _
"aabbbaa" & @CRLF & _
"abbbb" & @CRLF & _
"abbb" & @CRLF & _
"abbbbbb" & @CRLF & _
"aabbabbbb" & @CRLF & _
"aabbabbab" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")