$re = '/^a+(?:bba+)*(?:bb)?$/m';
$str = 'a
aaa
abb
abba
abbabb
abbabba
aaabbaabb
abbabbabbaaa
aba
baba
baabb
aabbbaa
abbbb
abbb
abbbbbb
aabbabbbb
aabbabbab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);