using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\{-\})|([\w\s]+)|\W";
string substitution = @"\1\2";
string input = @"{-}Lake Havasu City{-}Kingman-area{-}Lake Ha/vasu City{-}North Pointe-by-Read Homes{-}hola{*e}s!fsd3$^gdfg%
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}