import re
regex = re.compile(r"(\{-\})|([\w\s]+)|\W")
test_str = ("{-}Lake Havasu City{-}Kingman-area{-}Lake Ha/vasu City{-}North Pointe-by-Read Homes{-}hola{*e}s!fsd3$^gdfg% \n")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)