package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{1,6}[A-Z]),?`)
var str = `12A,123dasd 1F, 2F 323F d dsad 123D `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}