$re = '/([0-9]{1,6}[A-Z]),?/';
$str = '12A,123dasd 1F, 2F 323F d dsad 123D ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);