package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)=+\n(.+)\n=+`)
var str = `========================================
E:\#\1125 (2007) Victims Of Forgetting\
========================================
!Moros 1125 - 01 - Intro.mp3 ::INFO:: 442Kb
!Moros 1125 - 02 - Resp=ect For=.mp3 ::INFO:: 2.30Mb
=!Moros 1125 - 03 - Victims Of For=getting.mp3 ::INFO:: 2.74Mb
!Moros 1125 - 04 - Broken Wings.mp3 ::INFO:: 1.49Mb
!Moros 1125 - 05 - Rotten World.mp3 ::INFO:: 2.35Mb
!Moros 1125 - 06 - 1125crew.mp3 ::INFO:: 2.72Mb
!Moros 1125 - 07 - Around You.mp3 ::INFO:: 2.14Mb
========================================
E:\#\1125 (2007) Victims Of Forgetting\
========================================
!Moros 1125 - 01 - Intro.mp3 ::INFO:: 442Kb
!Moros 1125 - 02 - Respect For.mp3 ::INFO:: 2.30Mb
!Moros 1125 - 03 - Victims Of Forgetting.mp3 ::INFO:: 2.74Mb
!Moros 1125 - 04 - Broken Wings.mp3 ::INFO:: 1.49Mb
!Moros 1125 - 05 - Rotten World.mp3 ::INFO:: 2.35Mb
!Moros 1125 - 06 - 1125crew.mp3 ::INFO:: 2.72Mb
!Moros 1125 - 07 - Around You.mp3 ::INFO:: 2.14Mb
========================================
E:\#\1125 (2007) Victims Of Forgetting\
========================================
!Moros 1125 - 01 - Intro.mp3 ::INFO:: 442Kb
!Moros 1125 - 02 - Respect For.mp3 ::INFO:: 2.30Mb
!Moros 1125 - 03 - Victims Of Forgetting.mp3 ::INFO:: 2.74Mb
!Moros 1125 - 04 - Broken Wings.mp3 ::INFO:: 1.49Mb
!Moros 1125 - 05 - Rotten World.mp3 ::INFO:: 2.35Mb
!Moros 1125 - 06 - 1125crew.mp3 ::INFO:: 2.72Mb
!Moros 1125 - 07 - Around You.mp3 ::INFO:: 2.14Mb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}