use strict;
my $str = '========================================
E:\\#\\1125 (2007) Victims Of Forgetting\\
========================================
!Moros 1125 - 01 - Intro.mp3 ::INFO:: 442Kb
!Moros 1125 - 02 - Resp=ect For=.mp3 ::INFO:: 2.30Mb
=!Moros 1125 - 03 - Victims Of For=getting.mp3 ::INFO:: 2.74Mb
!Moros 1125 - 04 - Broken Wings.mp3 ::INFO:: 1.49Mb
!Moros 1125 - 05 - Rotten World.mp3 ::INFO:: 2.35Mb
!Moros 1125 - 06 - 1125crew.mp3 ::INFO:: 2.72Mb
!Moros 1125 - 07 - Around You.mp3 ::INFO:: 2.14Mb
========================================
E:\\#\\1125 (2007) Victims Of Forgetting\\
========================================
!Moros 1125 - 01 - Intro.mp3 ::INFO:: 442Kb
!Moros 1125 - 02 - Respect For.mp3 ::INFO:: 2.30Mb
!Moros 1125 - 03 - Victims Of Forgetting.mp3 ::INFO:: 2.74Mb
!Moros 1125 - 04 - Broken Wings.mp3 ::INFO:: 1.49Mb
!Moros 1125 - 05 - Rotten World.mp3 ::INFO:: 2.35Mb
!Moros 1125 - 06 - 1125crew.mp3 ::INFO:: 2.72Mb
!Moros 1125 - 07 - Around You.mp3 ::INFO:: 2.14Mb
========================================
E:\\#\\1125 (2007) Victims Of Forgetting\\
========================================
!Moros 1125 - 01 - Intro.mp3 ::INFO:: 442Kb
!Moros 1125 - 02 - Respect For.mp3 ::INFO:: 2.30Mb
!Moros 1125 - 03 - Victims Of Forgetting.mp3 ::INFO:: 2.74Mb
!Moros 1125 - 04 - Broken Wings.mp3 ::INFO:: 1.49Mb
!Moros 1125 - 05 - Rotten World.mp3 ::INFO:: 2.35Mb
!Moros 1125 - 06 - 1125crew.mp3 ::INFO:: 2.72Mb
!Moros 1125 - 07 - Around You.mp3 ::INFO:: 2.14Mb';
my $regex = qr/=+\n(.+)\n=+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}