using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"show me (\w+) ?(not|and)? ?(\w+)?";
string input = @"show me light
show me light not fear
show me light and grace";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}