$re = '/show me (\w+) ?(not|and)? ?(\w+)?/m';
$str = 'show me light
show me light not fear
show me light and grace';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);