#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\[(.*?)\](.*?)\[\/\1\]"
Local $sString = "[tag1]Test's Text Test Text Test Text Test Text." & @CRLF & _
"" & @CRLF & _
"Test Text Test Text Test "Text Test Text" Test Text Test Text." & @CRLF & _
"" & @CRLF & _
"Test Text? Test Text Test Text Test Text Test Text Test Text Test Text." & @CRLF & _
"" & @CRLF & _
"Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag1]" & @CRLF & _
"" & @CRLF & _
"[tag2]Test's Text Test Text Test Text Test Text." & @CRLF & _
"" & @CRLF & _
"Test Text Test Text Test "Text Test Text" Test Text Test Text." & @CRLF & _
"" & @CRLF & _
"Test Text? Test Text Test Text Test Text Test Text Test Text Test Text." & @CRLF & _
"" & @CRLF & _
"Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag2]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")