const regex = /\[(.*?)\](.*?)\[\/\1\]/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.*?)\\](.*?)\\[\\\/\\1\\]', 'sg')
const str = `[tag1]Test's Text Test Text Test Text Test Text.
Test Text Test Text Test "Text Test Text" Test Text Test Text.
Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.
Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag1]
[tag2]Test's Text Test Text Test Text Test Text.
Test Text Test Text Test "Text Test Text" Test Text Test Text.
Test Text? Test Text Test Text Test Text Test Text Test Text Test Text.
Test Text, Test Text Test Text Test Text Test Text Test Text Test Text Test Text.[/tag2]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}