package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]{1,3}((,[0-9]{3})*|([0-9]*))(\.[0]{2})?$`)
var str = `329223333333372.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}