$re = '/^[0-9]{1,3}((,[0-9]{3})*|([0-9]*))(\.[0]{2})?$/';
$str = '329223333333372.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);