#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<FilesMatch \"\(\^\\\.ht\|~\$\|\\\.bak\$\|\\\.BAK\$\|\\\.old\$\)\">(.*\n){1,}Order Allow,Deny Deny from all(.*\n){1,}<\/FilesMatch>(.*\n){1,}<DirectoryMatch \"\(\/CVS\/\|\.svn\)\">(.*\n){1,}Order Allow,Deny Deny from all(.*\n){1,}<\/DirectoryMatch>"
Local $sString = "<FilesMatch "(^\.ht|~$|\.bak$|\.BAK$|\.old$)">" & @CRLF & _
"Order Allow,Deny Deny from all" & @CRLF & _
"</FilesMatch>" & @CRLF & _
"<DirectoryMatch "(/CVS/|.svn)">" & @CRLF & _
"Order Allow,Deny Deny from all" & @CRLF & _
"</DirectoryMatch>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")