using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<FilesMatch \""\(\^\\\.ht\|~\$\|\\\.bak\$\|\\\.BAK\$\|\\\.old\$\)\"">(.*\n){1,}Order Allow,Deny Deny from all(.*\n){1,}<\/FilesMatch>(.*\n){1,}<DirectoryMatch \""\(\/CVS\/\|\.svn\)\"">(.*\n){1,}Order Allow,Deny Deny from all(.*\n){1,}<\/DirectoryMatch>";
string input = @"<FilesMatch ""(^\.ht|~$|\.bak$|\.BAK$|\.old$)"">
Order Allow,Deny Deny from all
</FilesMatch>
<DirectoryMatch ""(/CVS/|.svn)"">
Order Allow,Deny Deny from all
</DirectoryMatch>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}