package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\p{Lu}\p{Ll}*|\b\p{Ll}+\s+\p{Lu}\p{Ll}*`)
var str = `Igor Belogubov
Sergey Shilov`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}