re = /\b\p{Lu}\p{Ll}*|\b\p{Ll}+\s+\p{Lu}\p{Ll}*/
str = 'Igor Belogubov
Sergey Shilov'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end