using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G((?:[^\s""']+| (?!\s)|""[^""\\]*(?:\\.[^""\\]*)*""|'[^'\\]*(?:\\.[^'\\]*)*')*+)(\s+)";
string substitution = @"$1 ";
string input = @"'example' another_word";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}