re = /\G((?:[^\s"']+| (?!\s)|"[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')*+)(\s+)/
str = '\'example\' another_word'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result