$re = '/{{((?!contact\.firstName|contact\.lastName|contact\.phoneNumber|contact\.language)[^{}])*}}/';
$str = 'test {{debug}} {{contact.language}} test {{ {{ another word }} test {{test}} another {{contact.something}} {{contact.firstName}} {{contact.name}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);