const regex = /((<(\s*)(script)(\s*)(\/*)(\s*)>((.|\n)*?)<(\s*)(\/+)(\s*)(script)(\s*)>)|<(\s*)(\/*)(\s*)(script)(\s*)(\/*)(\s*)>)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<(\\s*)(script)(\\s*)(\\\/*)(\\s*)>((.|\\n)*?)<(\\s*)(\\\/+)(\\s*)(script)(\\s*)>)|<(\\s*)(\\\/*)(\\s*)(script)(\\s*)(\\\/*)(\\s*)>)*', '')
const str = `<script>alert('Hello World');
alert('Hello Back');<script>alert('Hello World');
alert('Hello Back');</script></script>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}