re = /((<(\s*)(script)(\s*)(\/*)(\s*)>((.|\n)*?)<(\s*)(\/+)(\s*)(script)(\s*)>)|<(\s*)(\/*)(\s*)(script)(\s*)(\/*)(\s*)>)*/
str = '<script>alert(\'Hello World\');
alert(\'Hello Back\');<script>alert(\'Hello World\');
alert(\'Hello Back\');</script></script>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end