$re = '/(?<=: )(.+?)(?=: |$)/';
$str = ': hostname: Oct 16 03:49:39.515: %BLA: message';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);