re = /(?<=: )(.+?)(?=: |$)/
str = ': hostname: Oct 16 03:49:39.515: %BLA: message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end