$re = '/\s{0,}[Yy]\s{0,}/m';
$str = 'ynY';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);