package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)\b\d+\.?\d*\s*(?:kg|gr?)\b`)
var str = `"some text 5kg another text 3 g more text 11.5gr end"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}