$re = '/(?i)\b\d+\.?\d*\s*(?:kg|gr?)\b/m';
$str = '"some text 5kg another text 3 g more text 11.5gr end"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);