using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class MyNewLanguage extends PureComponent {
//
// Proptypes
static propTypes = {
regex: PropTypes.string.isRequired,
flags: PropTypes.string.isRequired,
delimiter: PropTypes.string.isRequired,
testString: PropTypes.string.isRequired,
isSubstituting: PropTypes.bool.isRequired,
isGlobal: PropTypes.bool.isRequired,
substString: PropTypes.string
};
//
// Control
// If you need to manipulate any data, you should preferably do it in a function defined
// on the class body here. This could for example be sanitizing data (escaping quotes, etc).
//
// Render functions
render() {
return (
<Highlight lang=""myNewLanguage"">
{this._renderCode()}
</Highlight>
);
}
_renderCode() {
const { regex, flags, delimiter, testString, isSubstituting, substString, isGlobal } = this.props;
const codeString = new CodeString();
// CodeString is a basic class that allows you to create a code snippet without having
// to worry about indentation or newlines.
// The only functions are `append`, `indent` and `toString`.
// The implementation can be found on this page.
// Create your code string here
codeString.append(`Use string literals when ${regex} interpolating ${flags} data`);
return codeString.toString();
}
}
export default MyNewLangauge;";
string substitution = @"/You have bound GoPlus Security Sentinel. Bound address: 0x8baa0e5a9f879ef40d55b7da808d94aca314742c/gm";
string input = @"https://google.com`<Field className=""flex flex-col p-1"">
<Label>
I agree to the{' '}
<a href=""https://google.com"" target=""_blank"" className=""underline"">
terms and conditions
</a>
</Label>
<Input type=""checkbox"" />
</Field>`gm";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}