import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class MyNewLanguage extends PureComponent \\{\n\n"
+ " //\n"
+ " // Proptypes\n\n"
+ " static propTypes = \\{\n"
+ " regex: PropTypes.string.isRequired,\n"
+ " flags: PropTypes.string.isRequired,\n"
+ " delimiter: PropTypes.string.isRequired,\n"
+ " testString: PropTypes.string.isRequired,\n"
+ " isSubstituting: PropTypes.bool.isRequired,\n"
+ " isGlobal: PropTypes.bool.isRequired,\n"
+ " substString: PropTypes.string\n"
+ " \\};\n\n"
+ " //\n"
+ " // Control\n\n"
+ " // If you need to manipulate any data, you should preferably do it in a function defined \n"
+ " // on the class body here. This could for example be sanitizing data (escaping quotes, etc).\n\n"
+ " //\n"
+ " // Render functions\n\n"
+ " render() \\{\n"
+ " return (\n"
+ " <Highlight lang=\"myNewLanguage\">\n"
+ " \\{this._renderCode()\\}\n"
+ " </Highlight>\n"
+ " );\n"
+ " \\}\n\n"
+ " _renderCode() \\{\n"
+ " const \\{ regex, flags, delimiter, testString, isSubstituting, substString, isGlobal \\} = this.props;\n\n"
+ " const codeString = new CodeString();\n"
+ " \n"
+ " // CodeString is a basic class that allows you to create a code snippet without having\n"
+ " // to worry about indentation or newlines.\n\n"
+ " // The only functions are `append`, `indent` and `toString`.\n"
+ " // The implementation can be found on this page.\n\n"
+ " // Create your code string here\n"
+ " codeString.append(`Use string literals when $\\{regex\\} interpolating $\\{flags\\} data`);\n"
+ " \n"
+ " return codeString.toString();\n"
+ " \\}\n\n"
+ "\\}\n\n"
+ "export default MyNewLangauge;";
final String string = "https://google.com`<Field className=\"flex flex-col p-1\">\n"
+ " <Label>\n"
+ " I agree to the{' '}\n"
+ " <a href=\"https://google.com\" target=\"_blank\" className=\"underline\">\n"
+ " terms and conditions\n"
+ " </a>\n"
+ " </Label>\n"
+ " <Input type=\"checkbox\" />\n"
+ "</Field>`gm";
final String subst = "/You have bound GoPlus Security Sentinel. Bound address: 0x8baa0e5a9f879ef40d55b7da808d94aca314742c/gm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}