$re = '/[a-z]+\+[a-z]+\@[a-z]+\.[a-z]+\-[a-z]+\.[a-z]+/m';
$str = 'you+me@some.domain-domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);