re = /[a-z]+\+[a-z]+\@[a-z]+\.[a-z]+\-[a-z]+\.[a-z]+/m
str = 'you+me@some.domain-domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end