package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\B(#[a-z0-9])\w+)`)
var str = `I need to match only words like #these.
Ignore the ones like @#this , !#this and in#ignore.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}