const regex = /(\B(#[a-z0-9])\w+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\B(#[a-z0-9])\\w+)', 'gi')
const str = `I need to match only words like #these.
Ignore the ones like @#this , !#this and in#ignore.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}