# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^b]:[^,]*,?//gm;t' <<< "a:ABC,b:SDSD,c:213123#a:SDS,b:UIOU,c:89797#a:TYRQQQW,b:UIOUIOYYO,c:546654 a:DFSS,b:TYRTTN,c:12323#a:HJH,b:YTUUUTYUTYT,c:67890 a:TYY,b:OPIUIU,c:86768"