$re = '/[^b]:[^,]*,?/m';
$str = 'a:ABC,b:SDSD,c:213123#a:SDS,b:UIOU,c:89797#a:TYRQQQW,b:UIOUIOYYO,c:546654 a:DFSS,b:TYRTTN,c:12323#a:HJH,b:YTUUUTYUTYT,c:67890 a:TYY,b:OPIUIU,c:86768';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;