package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[-+]?\d+(\.\d+)?`)
var str = `2.3434 -3434.22 +23.2323 2323`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}