#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "3(?:\.\d+)*\.\s*"
Local $sString = "3.1. Cre" & @CRLF & _
"3.1.1. Im" & @CRLF & _
"3.1.1.1. O" & @CRLF & _
"3.1.1.2. Ce" & @CRLF & _
"3.1.1.3. Part" & @CRLF & _
"3.1.2. ED" & @CRLF & _
"3.1.2.1. Ow" & @CRLF & _
"3.1.2.2. ED" & @CRLF & _
"3.1.3. OF" & @CRLF & _
"3.1.3.1. O" & @CRLF & _
"3.1.3.2. O" & @CRLF & _
"3.1.3.3. O" & @CRLF & _
"3.1.3.4. O" & @CRLF & _
"3.1.4. Sc" & @CRLF & _
"3.1.5. In" & @CRLF & _
"3.1.6. Vi" & @CRLF & _
"3.1.7. Bu" & @CRLF & _
"3.1.8. Ho" & @CRLF & _
"3.1.8.1. Ou" & @CRLF & _
"3.1.8.2. In" & @CRLF & _
"3.1.9. Pa" & @CRLF & _
"3.1.9.1. Re" & @CRLF & _
"3.1.9.2. Re" & @CRLF & _
"3.1.9.3. Pr" & @CRLF & _
"3.1.9.3.1. Ou" & @CRLF & _
"3.1.9.3.2. Sp" & @CRLF & _
"3.1.9.3.3. In" & @CRLF & _
"3.1.9.3.4. In"
Local $sSubst = "\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)